IDEA中Maven下载不了依赖,百度了各种方法没什么用,逼我出绝招解决

项目想下载一个依赖,在idea中死都下不了,查看网上各种解决方案都没有效果,出绝招,我使用命令下载jar然后导入到项目引用的maven仓库

类似这种命令:mvn install:install-file -Dfile=d:\setup\dubbo-2.8.4.jar -DgroupId=com.alibaba -DartifactId=dubbo -Dversion=2.8.4 -Dpackaging=jar

举例:

	   <dependency>
		   <groupId>net.sf.json-lib</groupId>
		   <artifactId>json-lib</artifactId>
		   <version>2.4</version>
	   </dependency>
wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw==uploading.4e448015.gif转存失败重新上传取消

上面这个是我要下载的依赖

先去中央仓库,下好包。我这里把下载的包放到setup文件夹下

wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw==uploading.4e448015.gif转存失败重新上传取消

使用cmd打开命令行输入mvn install:install-file -Dfile=d:\setup\json-lib-2.4-jdk15.jar -DgroupId=net.sf.json-lib -DartifactId=json-lib -Dversion=2.4 -Dpackaging=jar回车就搞定了

再来一个例子:

我在进行string类型,json类型,map类型转化时,除了fastjson依赖还加了上面的依赖,但是运行时再次报错java.lang.ClassNotFoundException: net.sf.ezmorph.Morpher

原因分析:
使用JSON时,除了要导入JSON网站上面下载的json-lib-2.2-jdk15.jar包之外,
还必须有其它几个依赖包:
commons-beanutils.jar,commons-httpclient.jar,commons-lang.jar,ezmorph.jar,morph-1.0.1.jar 这几个包也是需要导入的.
如果缺少里面的:ezmorph.jar包,则即出现上述异常。
 
解决办法:
在pom.xml中添加依赖:

    <dependency>
        <groupId>net.sf.ezmorph</groupId>
        <artifactId>ezmorph</artifactId>
        <version>1.0.6</version>
    </dependency>
所以还要加一个依赖

先去仓库服务https://maven.aliyun.com/mvn/search

wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw==uploading.4e448015.gif转存失败重新上传取消

下载jar包放到setup文件夹(这个文件夹名字自己起)和命令对应就行

wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw==uploading.4e448015.gif转存失败重新上传取消

运行cmd打开命令窗口,输入命令:

mvn install:install-file -Dfile=d:\setup\ezmorph-1.0.6.jar -DgroupId=net.sf.ezmorph -DartifactId=ezmorph -Dversion=1.0.6 -Dpackaging=jar

如果出现这个

wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw==uploading.4e448015.gif转存失败重新上传取消

仔细观察你的命令:我的命令是net.sf.ezmorph-DartifactId在-之前要加空格

mvn compile  没有问题,mvn package的时候报如下错误:

Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.5:test

解决方法:
打包跳过测试有两种方法
一是命令行,
mvn clean package -Dmaven.test.skip=true
二是写入pom文件,
<plugin>  
        <groupId>org.apache.maven.plugins</groupId>  
        <artifactId>maven-surefire-plugin</artifactId>  
        <version>2.4.2</version>  
        <configuration>  
          <skipTests>true</skipTests>  
        </configuration>  
</plugin>  
在项目的pom.xml中加上依赖

如果出现这个

wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw==uploading.4e448015.gif转存失败重新上传取消

说明已经搞好了

举例:

mvn install:install-file -Dfile=d:\setup\commons-beanutils-1.9.2.jar -DgroupId=commons-beanutils -DartifactId=commons-beanutils -Dversion=1.9.2 -Dpackaging=jar

 

java小丑 CSDN认证博客专家 资深研发 博客专家 自媒体工作者
我是廖志伟,一名java开发工程师,CSDN博客专家,多年一线研发经验,曾就职多家互联网公司,任Java开发工程师职位,参与多个千万级并发互联网产品研发,对大型分布式,高并发及微服务架构有非常深入研究。
已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 博客之星2020 设计师:CY__ 返回首页
实付 39.90元
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值